Shared Clipboard Not Working

I had come across this issue quite a few times when the clipboard shared between my local and remote Windows sessions did not work. Each time, I had to close my remote session and open it again to resolve the problem. Even though this took only seconds it became annoying and I tried to look for the root cause.

I found a good article on MSDN blog that explains how shared clipboard works and what causes it not to work properly. Have a look.

To fix the problem I had to open Task Manager on the remote machine and find the rdpclip.exe process that is associated to my user (other users may have their own rdpclip.exe process running). I killed that process and then tried “File > New Task (Run…)” in Task Manager and types in rdpclip and confirmed. A new rdpclip.exe process was created for my user and the shared clipboard started working again.

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google+ photo

You are commenting using your Google+ account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

%d bloggers like this: